Issues in Latest Mobile App Release

Incident Report for easyMoney

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 08:37 UTC

Monitoring

A fix has been implemented, and we are monitoring the results.
Posted Aug 20, 2025 - 07:53 UTC

Identified

We're currently experiencing an issue with our mobile app on both iOS and Android platforms. Affected users are currently unable to log in through the app. Our team is actively working on a fix, and a new version will be released as soon as possible. In the meantime, you can continue to access your account by logging in through our web platform.
Posted Aug 19, 2025 - 08:59 UTC
This incident affected: 📱easyMoney App.